normal TRM240

More
21 Feb 2021 16:36 #2088 by TICONTROLSRL
TRM240 was created by TICONTROLSRL
Buongiorno,
dovrei usare il modem TRM240 per trasmissione dati CSD.
La SIM di test che sto usando è abilitata al traffico M2M.
Con configurazione di fabbrica ho provato a inviare il comando per la connessione al DCE remoto attraverso il comando AT: "ATDnumero" ma il modem risponde solamente "OK" ma la connessione dati non viene instaurata.
Qualcuno saprebbe indicarmi gentilmente i comandi AT di riferimento da impostare per settare il modem in modo trasmissione dati CSD?
Grazie per il Vs. cortese supporto
Lucio

Please Log in or Create an account to join the conversation.

More
22 Feb 2021 14:54 #2091 by marcom
Replied by marcom on topic TRM240
Buongiorno,

Per prima cosa assicurati che entrambi i tuoi dispositivi siano in modalità 2G o 3G:
AT + QCFG = "nwscanmode", 1 - Solo GSM
AT + QCFG = "nwscanmode", 2 - solo WCDMA


Quindi chiama l'altro dispositivo:
ATD<numero>



Non dimenticare di fare una foto sull'altro dispositivo:
ATA


Le chiamate CSD funzionano solo in modalità 2G / 3G

A disposizione per ulteriori informazioni
Cordiali saluti

Marcom S.r.l.
via della Metallurgia, 11
37139 - Verona (VR)

Please Log in or Create an account to join the conversation.

More
02 Mar 2021 10:20 #2103 by TICONTROLSRL
Replied by TICONTROLSRL on topic TRM240
Buongiorno,
sto riscontrando un ulteriore problema con il driver del modem su Win10 Pro.
Ho installato il seguente driver scaricato dal sito di Teltonika: Quectel LTE 5G Windows USB Driver V2.1.zip - 2019-07-08.
Quando collego il modem alla porta USB del pc la porta COM sembra chiudersi e riaprirsi in continuazione impedendo l'invio di comandi AT attraverso Hyperterminal. (si veda video allegato di "Gestione dispositivi")
Come risolvo tale problema?
Grazie
Lucio

Please Log in or Create an account to join the conversation.

More
02 Mar 2021 10:21 #2104 by marcom
Replied by marcom on topic TRM240
Buongiorno,

così di primo acchito sembra un problema di alimentazione del dispositivo via USB.
Provi ad utilizzare un'altra porta USB oppure un HUB USB alimentato.

A disposizione per ulteriori informazioni
Cordiali saluti

Marcom S.r.l.
via della Metallurgia, 11
37139 - Verona (VR)

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 17:55 #2122 by TICONTROLSRL
Replied by TICONTROLSRL on topic TRM240
Salve,
grazie per l'indicazione, il problema era dovuto proprio all'alimentazione data al dispositivo dalla porta USB del TE. Risolto con un hub USB alimentato.

Ora però mi sto scontrando con un ulteriore problema.
L'applicativo sw che sto usando necessita che il modem restituisca il segnale CTS alto per la sapere che il modem è pronto a ricevere comandi (ATDxxxx). All'avvio il modem parte con il CTS basso pertanto l'applicativo sw non riconosce il modem connesso o pronto. Come da manuale del modem (Quectel - EC25&EC21 AT Commands Manual - Cap.3.3) ho provato a settare il comando AT+IFC=2,2 per abilitare RTS flow control e CTS flow control attivi ma senza effetto. Infatti se provo a leggere il comando appena impostato con AT+IFC? la risposta è sempre +IFC: 0,0 pertanto il controllo RTS e CTS rimane non abilitato e in contradizione con quanto specificato sul manuale stesso.
Qualche indicazione per risolvere il problema?
Ringrazio e saluto cordialmente.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum
Avviso
  • Prices shown are already without VAT.